注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

俊峰 电子 电脑

伸手摘星,未必如愿,但至少不会弄脏你的手

 
 
 

日志

 
 
关于我

荆门市东宝中学 熊军锋 任教学科:网络管理 擅长的技术:专业开发8位 16位 32位单片机,电脑人机界面一体化控制,工业控制,数控产品及嵌入式系统开发等。 曾经做过的项目:数码发电机,摩托车综合仪表,变频器,打包机控制

网易考拉推荐

CISCO三层交换机+二层交换机配置VLAN的实例  

2009-12-29 22:46:34|  分类: 网络技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
   Cisco的VLAN实现通常是以端口为中心的。与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态
的.形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP (VLAN Trunking Protocol)Server上建立VLAN,然后将每个端
口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。
        动态VLAN形成很简单,由端口决定自己属于哪个VLAN。即我们先建立一个VMPS(VLAN Membership Policy Server)VLAN管理策略服务
器,里面包含一个文本文件,文件中存有与VLAN映射的MAC地址表。交换机根据这个映射表决定将端口分配给何种VLAN。这种方法有很大的优势
,但是创建数据库是一项非常艰苦而且非常繁琐的工作。
  
 下面以实例说明如何在一个典型的快速以太局域网中实现VLAN。所谓典型的局域网就是指由一台具备三层交换功能的核心交换机接几台分支
交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:COM;分支交换机分别为:PAR1、PAR2、PAR3……,分别通过Port1的光线
模块与核心交换机相连;并且假设VLAN名称分别为COUNTER、MARKET、MANAGING……。
  
  1、设置VTP DOMAIN   
  称为管理域。交换VTP更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设
置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的VLAN列表。
  COM#vlan database 进入VLAN配置模式
  
  COM(vlan)#vtp domain COM 设置VTP管理域名称COM
  
  COM(vlan)#vtp server 设置交换机为服务器模式
  PAR1#vlan database 进入VLAN配置模式
  PAR1(vlan)#vtp domain COM 设置VTP管理域名称COM
   PAR1(vlan)#vtp Client 设置交换机为客户端模式
  PAR2#vlan database 进入VLAN配置模式
   PAR2(vlan)#vtp domain COM 设置VTP管理域名称COM
    PAR2(vlan)#vtp Client 设置交换机为客户端模式
  PAR3#vlan database 进入VLAN配置模式
  PAR3(vlan)#vtp domain COM 设置VTP管理域名称COM
   PAR3(vlan)#vtp Client 设置交换机为客户端模式
 注意:这里设置交换机为Server模式是指允许在本交换机上创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他
交换机传递来的最新的VLAN信息;Client模式是指本交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可以同步由本
VTP域中其他交换机传递来的VLAN信息。
 2、配置中继
  为了保证管理域能够覆盖所有的分支交换机,必须配置中继。Cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的
ISL标签。ISL(Inter-Switch link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协
议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。
  在核心交换机端配置如下:
 COM(config)#interface gigabitEthernet 2/1
 COM(config-if)#switchport
 COM(config-if)#switchport trunk encapsulation isl
  COM(config-if)#switchport mode trunk
 COM(config)#interface gigabitEthernet 2/2
  COM(config-if)#switchport
 COM(config-if)#switchport trunk encapsulation isl
  COM(config-if)#switchport mode trunk
 COM(config)#interface gigabitEthernet 2/3
 COM(config-if)#switchport
 COM(config-if)#switchport trunk encapsulation isl
 COM(config-if)#switchport mode trunk
  在分支交换机端配置如下:
  PAR1(config)#interface gigabitEthernet 0/1
    PAR1(config-if)#switchport mode trunk
    PAR2(config)#interface gigabitEthernet 0/1
    PAR2(config-if)#switchport mode trunk
   PAR3(config)#interface gigabitEthernet 0/1
   PAR3(config-if)#switchport mode trunk
 此时,管理域算是设置完毕了。
   3、创建VLAN
  
  一旦建立了管理域,就可以创建VLAN了。
  COM(vlan)#Vlan 10 name COUNTER 创建了一个编号为10名字为COUNTER的 VLAN
  COM(vlan)#Vlan 11 name MARKET 创建了一个编号为11名字为MARKET的 VLAN
  COM(vlan)#Vlan 12 name MANAGING 创建了一个编号为12名字为MANAGING的 VLAN
   注意,这里的VLAN是在核心交换机上建立的,其实,只要是在管理域中的任何一台VTP属性为Server的交换机上建立VLAN,它就会通过VTP
通告整个管理域中的所有的交换机。但是如果要将交换机的端口划入某个VLAN,就必须在该端口所属的交换机上进行设置。
  4、将交换机端口划入VLAN
  
  例如,要将PAR1、PAR2、PAR3……分支交换机的端口1划入COUNTER VLAN,端口2划入MARKET VLAN,端口3划入MANAGING VLAN……
  
    PAR1(config)#interface fastEthernet 0/1 配置端口1
    PAR1(config-if)#switchport access vlan 10 归属COUNTER VLAN
  PAR1(config)#interface fastEthernet 0/2 配置端口2
  PAR1(config-if)#switchport access vlan 11 归属MARKET VLAN
  PAR1(config)#interface fastEthernet 0/3 配置端口3
    PAR1(config-if)#switchport access vlan 12 归属MANAGING VLAN
  PAR2(config)#interface fastEthernet 0/1 配置端口1
  PAR2(config-if)#switchport access vlan 10 归属COUNTER VLAN
    PAR2(config)#interface fastEthernet 0/2 配置端口2
  PAR2(config-if)#switchport access vlan 11 归属MARKET VLAN
    PAR2(config)#interface fastEthernet 0/3 配置端口3
   PAR2(config-if)#switchport access vlan 12 归属MANAGING VLAN
    PAR3(config)#interface fastEthernet 0/1 配置端口1
    PAR3(config-if)#switchport access vlan 10 归属COUNTER VLAN
   PAR3(config)#interface fastEthernet 0/2 配置端口2
  PAR3(config-if)#switchport access vlan 11 归属MARKET VLAN
     PAR3(config)#interface fastEthernet 0/3 配置端口3
     PAR3(config-if)#switchport access vlan 12 归属MANAGING VLAN
   5、配置三层交换
  到这里,VLAN已经基本划分完毕。但是,VLAN间如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配
IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给VLAN所有的节点分配动态IP地址。下面就这两种情况分别介绍。
  我们假设给VLAN COUNTER分配的接口Ip地址为172.16.58.1/24,网络地址为:172.16.58.0,VLAN
 MARKET分配的接口Ip地址为172.16.59.1/24,网络地址为172.16.59.0,VLAN
  MANAGING分配的接口Ip地址为172.16.60.1/24,网络地址为172.16.60.0……。如果动态分配IP地址,则设网络上的DHCP服务器IP地址为
172.16.1.11。
 (1)给VLAN所有的节点分配静态IP地址
  
  首先在核心交换机上分别设置各VLAN的接口IP地址,如下所示:
  
  COM(config)#interface vlan 10
    COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP
  COM(config)#interface vlan 11
   COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP
   COM(config)#interface vlan 12
  COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP
  再在各接入VLAN的计算机上设置与所属VLAN的网络地址一致的IP地址,并且把默认网关设置为该VLAN的接口地址。这样,所有的VLAN也可
以互访了。
  (2)给VLAN所有的节点分配动态IP地址
  首先在核心交换机上分别设置各VLAN的接口IP地址和DHCP服务器的IP地址,如下所示:
  COM(config)#interface vlan 10
  COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP
    COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
  COM(config)#interface vlan 11
  COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP
   COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
  COM(config)#interface vlan 12
  COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP
  COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
  再在DHCP服务器上设置网络地址分别为172.16.58.0,172.16.59.0,172.16.60.0的作用域,并将这些作用域的“路由器”选项设置为对应
VLAN的接口IP地址。这样,可以保证所有的VLAN也可以互访了。
 最后在各接入VLAN的计算机进行网络设置,将IP地址选项设置为自动获得IP地址即可。
本文来自:中国IT项目管理网(www.itpmp.org)  原文链接:http://www.itpmp.org/html/NetworkProject/Switch/20080507/1362.html
  评论这张
 
阅读(316)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017