注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

俊峰 电子 电脑

伸手摘星,未必如愿,但至少不会弄脏你的手

 
 
 

日志

 
 
关于我

荆门市东宝中学 熊军锋 任教学科:网络管理 擅长的技术:专业开发8位 16位 32位单片机,电脑人机界面一体化控制,工业控制,数控产品及嵌入式系统开发等。 曾经做过的项目:数码发电机,摩托车综合仪表,变频器,打包机控制

网易考拉推荐

Cisco3524交换机配置VLAN实例  

2009-03-17 15:19:41|  分类: 网络技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

Cisco 3548(3524) 交换机:

  第一次连接交换机,配置终端参数为:

  波特率:9600;数据位:8;停止位:1;奇偶校验:无;流控制:无。

  通过串口线连上路由器后,按回车,即可看到配置向导:

  (假如不是第一次配置,可以进入超级用户模式后用命令setup调用以下过程)

  

  --- System Configuration Dialog ---

  

  At any point you may enter a question mark ? for help.任何时候可以打?取得帮助

  Use ctrl-c to abort configuration dialog at any prompt.按Ctrl-C可以取消并退出

  Default settings are in square brackets [].默认参数在[]中

  

  Continue with configuration dialog? [yes/no]: y继续交互配置吗?回答:y

  Enter IP address: 10.1.1.249ip地址

  Enter IP netmask: 255.255.255.0子网掩码

  Would you like to enter a default gateway address? [yes]: y设置默认网关?y

  IP address of default gateway: 10.1.1.254默认网关

  Enter host name [3548_9A]:

  

  The enable secret is a one-way cryptographic secret used

  instead of the enable passWord when it exists.

  

  Enter enable secret: _password输入超级用户密码

  

  Would you like to configure a Telnet password? [yes]: y

  Enter Telnet password: _password输入telnet密码

  Would you like to enable as a cluster command switch? [yes/no]: n集群模式?n

  

  The following configuration command script was created:已建立以下配置信息

  

  ip subnet-zero

  interface VLAN1

  ip address 10.1.1.249 255.255.255.0

  ip default-gateway 10.1.1.254

  enable secret 5 $1$biZ3$AOLb9cMTtBwMtGB9lyBzr.

  line vty 0 15

  password _domainwlzx

  snmp community private rw

  snmp community public ro

  !

  end

  

  Use this configuration? [yes/no]:使用该配置信息吗? y

  

  修改配置:

  

  禁止通过snmp治理:

  3548>enable

  password:

  3548#config term

  3548(config)#no snmp community private

  3548(config)#no snmp community public

  

  接着配置干道:(确定上级交换机对应端口已设为干道模式)

  3548(config)#inter g0/1 选择第一个千兆口

  3548(config if)# switchport mode trunk设为干道模式

  假如g0/2用于连接另一台3548,也设为干道

  3548(config)#inter g0/2

  3548(config if)# switchport mode trunk

  返回

  3548(config if)# exit

  3548(config)# exit

  3548#

  验证: ping 10.1.1.254

  

  配置Vlan数据:

  3548#vlan database

  3548(vlan)#reset清除以前的配置

  3548(vlan)#vtp client设为vtp客户模式

  3548(vlan)#vtp domain _domainvtp域是_domain

  3548(vlan)#vtp password ********设定vtp域密码

  3548(vlan)#exit

  3548#

  验证:show vtp status显示vlan 数据

  show vtp counters

  show vlan

  同步后看到的vlan数目和名称应与6506上的一致

  

  指定端口到Vlan、配置端口为portfast方式(快速建立连接):

  方法1:命令方式

  3548#config term

  3548(config)#inter f0/1配置1号快速以太网端口

  3548(config if)# switchport Access vlan 2指定端口到Vlan 2

  3548(config if)# spanning-tree portfast配置端口为portfast方式

  3548(config)#inter f0/2配置1号快速以太网端口

  3548(config if)# switchport access vlan 2指定端口到Vlan 2

  3548(config if)# spanning-tree portfast配置端口为portfast方式

  ...对每个要设定的端口重复上述步骤。

  3548(config if)# exit

  3548(config)# exit

  3548#

  方法1:Web 方式

  (预先要安装插件:jre-1-2-2-005-win-i-09-mar-2000.exe)

  打开浏览器连接设备:在地址栏输入设备的治理页面url,如3548_9a(10.1.1.248)为:http://10.1.1.249/basiccfg.Html

  选中菜单port -> port configure -> 设port fast 为Enable

  选中菜单vlan -> vlan membership -> 指定端口所属的Vlan号 可同时指定多个端口

  

  

  ! 注重: 假如把一个端口指定到不存在的VLAN上,3548交换机的VLAN同步会异常,此时应该为正确VLAN并重新“配置Vlan数据”

  

  保存配置信息:

  方法1:命令方式

  3548# write ( 或 copy running-config startup-config )

  方法1:Web 方式

  选中设备(而不是单个端口),点击save configure按钮。

  

  

  3548_9A#show run

  Building configuration...

  

  Current configuration:

  !

  version 12.0#软件版本

  no service pad

  service timestamps debug uptime

  service timestamps log uptime

  no service password-encryption

  !

  hostname 3548_9A#系统名称

  !

  enable secret 5 $1$4ZMs$rfC.g/nN.owt3eW2uoCL/0#加密后的enable密码

  !

  !

  !

  !

  !

  !

  ip subnet-zero

  !

  !

  !

  interface FastEthernet0/1#模块0的1号快速以太网接口

  switchport access vlan 5#指定端口0/1到vlan 5

  spanning-tree portfast#假如接的是工作站,指定端口为portfast方式(不运行生成树协议,加快建立连接速度)

  !

  interface FastEthernet0/2

  spanning-tree portfast#默认情况下端口属vlan 1

  !

  interface FastEthernet0/3

  spanning-tree portfast

  !

  interface FastEthernet0/4

  spanning-tree portfast

  !

  interface FastEthernet0/5

  spanning-tree portfast

  !

  interface FastEthernet0/6

  spanning-tree portfast

  !

  interface FastEthernet0/7

  spanning-tree portfast

  !

  interface FastEthernet0/8

  spanning-tree portfast

  !

  interface FastEthernet0/9

  spanning-tree portfast

  !

  interface FastEthernet0/10

  spanning-tree portfast

  !

  interface FastEthernet0/11

  spanning-tree portfast

  !

  interface FastEthernet0/12

  spanning-tree portfast

  !

  interface FastEthernet0/13

  spanning-tree portfast

  !

  interface FastEthernet0/14

  spanning-tree portfast

  !

  interface FastEthernet0/15

  spanning-tree portfast

  !

  interface FastEthernet0/16

  spanning-tree portfast

  !

  interface FastEthernet0/17

  spanning-tree portfast

  !

  interface FastEthernet0/18

  spanning-tree portfast

  !

  interface FastEthernet0/19

  spanning-tree portfast

  !

  interface FastEthernet0/20

  spanning-tree portfast

  !

  interface FastEthernet0/21

  spanning-tree portfast

  !

  interface FastEthernet0/22

  spanning-tree portfast

  !

  interface FastEthernet0/23

  spanning-tree portfast

  !

  interface FastEthernet0/24

  spanning-tree portfast

  !

  interface FastEthernet0/25

  spanning-tree portfast

  !

  interface FastEthernet0/26

  spanning-tree portfast

  !

  interface FastEthernet0/27

  spanning-tree portfast

  !

  interface FastEthernet0/28

  spanning-tree portfast

  !

  interface FastEthernet0/29

  spanning-tree portfast

  !

  interface FastEthernet0/30

  spanning-tree portfast

  !

  interface FastEthernet0/31

  spanning-tree portfast

  !

  interface FastEthernet0/32

  spanning-tree portfast

  !

  interface FastEthernet0/33

  spanning-tree portfast

  !

  interface FastEthernet0/34

  spanning-tree portfast

  !

  interface FastEthernet0/35

  spanning-tree portfast

  !

  interface FastEthernet0/36

  spanning-tree portfast

  !

  interface FastEthernet0/37

  spanning-tree portfast

  !

  interface FastEthernet0/38

  spanning-tree portfast

  !

  interface FastEthernet0/39

  spanning-tree portfast

  !

  interface FastEthernet0/40

  spanning-tree portfast

  !

  interface FastEthernet0/41

  spanning-tree portfast

  !

  interface FastEthernet0/42

  spanning-tree portfast

  !

  interface FastEthernet0/43

  spanning-tree portfast

  !

  interface FastEthernet0/44

  spanning-tree portfast

  !

  interface FastEthernet0/45

  spanning-tree portfast

  !

  interface FastEthernet0/46

  spanning-tree portfast

  !

  interface FastEthernet0/47

  spanning-tree portfast

  !

  interface FastEthernet0/48

  spanning-tree portfast

  !

  interface GigabitEthernet0/1

  switchport mode trunk#设置G0/1为运行isl协议的干道,默认答应所有vlan通过

  !

  interface GigabitEthernet0/2

  !

  interface VLAN1

  ip address 10.1.1.249 255.255.255.0#本交换机的IP地址

  no ip directed-broadcast

  no ip route-cache

  !

  ip default-gateway 10.1.1.254#默认网关

  snmp-server engineID local 00000009020000036BC

  !

  line con 0

  transport input none

  stopbits 1

  line vty 0 4

  password _password#telnet密码

  login

  line vty 5 15

  password _password#telnet密码

  login

  !

  end

  评论这张
 
阅读(301)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017